Search form

Main menu

My Account Menu

Turn off ovm_printer

ericew
ericew
Full Access
9 posts

Hi,

I added bunch `ovm_field_int() to my OVM environment and this is actually causing plenty of printing. I think this is printed from ovm_printer. May I know how to completely remove the printing?

Currently the printing look like this
# --------------------------------------------------
# Name Type Size Value
# --------------------------------------------------

Thanks.

Answers

vdadwal
vdadwal
Forum Access
46 posts

Hi
I guess their are some switches which you can use while defining the attribute definition in the component. I don't remember them over the top of my head, but check it out.

-Vikram Dadwal

Comments on this answer

Hi,

There are multiple ways to disable the messages in OVM. Some of them are mentioned below :

1. If you have maintained the good verbosity level for different messages based on their importance then you can use command line switch '+OVM_VERBOSITY=OVM_LOW'

2. You can use the 'set_report_id_*' function to disable the messages from the component.